Skip to content

WaytoICT

Explore ICT Technology, Build Your Tech Path

登录注册
Menu
  • 首页
  • 技术文章
  • 市场观点
技术文章 光通信 · 硅光 · CPO 技术解读 → 市场观点 财报 · 趋势 · 产业格局 →
Menu

什么是位索引显式复制(BIER)组播技术?

Posted on 2020-12-212026-09-06 by 通往ICT之路

新闻:“中兴通讯高端路由器独家中标全国首个BIER组播项目”,中兴通讯高端路由器ZXR10 M6000-S独家中标南京紫金山实验室新型骨干网技术试验BIER(Bit Index Explicit Replication,位索引显式复制)子任务设备采购项目,该项目为全国首个BIER组播试验局项目。

那么,你知道什么是BIER(Bit Index Explicit Replication,位索引显式复制)技术吗?

技术背景

BIER由IETF提出,并在RFC 8279 中进行了描述。基本思想是从网络中间的设备中删除依赖于IPMC组的状态以及建立显式树的需求,以提高IPMC域的可伸缩性。这是通过向IPMC数据包添加BIER标头来实现的。在这样的BIER域中,仅根据此报头转发数据包。为什么会提出BIER技术,有什么现实需求?通信百科公众号整理发布

传统的IP组播(IPMC)有效地转发了一对多流量,并被用于IPTV或组播VPN(mVPN)等服务。在本文中,我们解释了传统IPMC的基本概念,描述了其缺点,并提出了位索引显式复制(BIER)作为解决方案。

IPMC组可以对应一个特定的IPTV频道。目的地为IPMC组地址的数据包将转发给其所有成员。接收方利用IGMP / MLD(Internet组管理协议,RFC 3376 /多播侦听器发现,RFC 3810)加入IPMC组。在IPMC域中,典型的IPMC协议使用网络内流量复制来确保最多单个数据包副本遍历每个链接以到达多个接收者。为此,他们可能为每个IPMC组建立一个IPMC树(可能为每个源),沿该组转发该组的流量。图1中显示了该概念。此类协议的示例包括PIM(协议无关多播,RFC 7761),mLDP(多播标签分发协议)或RSVP-TE / P2MP(资源预留协议–流量工程,RFC 3209,点对多点RFC 4875)。IPMC树需要在中间跃点中转发信息,以下我们将其称为“状态”。

什么是位索引显式复制(BIER)组播技术?

两个组播树

事实证明,某些针对带有静态分发树的特殊用例的IPMC解决方案,尤其是PIM的实现,是有用且可管理的。然而,传统IPMC解决方案的可扩展性有限。主要有如下不足:通信百科公众号整理发布

P0:设备必须按IPMC组存储状态。P1:每当IPMC组启动,更改或停止时,IPMC协议必须主动创建,更改和拆除IPMC树。P2:在拓扑更改的情况下,转发结构可能需要更改。因此,所有IPMC组的状态可能都需要调整。该过程所需的时间与IPMC组的数量成比例。

定义及原理简介

为此,BIER (Bit Index Explicit Replication)技术采用了一种新的思想来解决传统组播中的突出问题,那就是将组播报文要发送到目的节点的集合以Bit String的方式封装在报文头部发送。该技术允许运营商有效转发IPMC流量,而无需在中间设备中使用明确的IPMC树状态。

什么是位索引显式复制(BIER)组播技术?

在上图中,流量通过位转发入口路由器(BFIR)进入BIER域,并被有效地复制到潜在的许多位转发出口路由器(BFER)。BFIR将BIER标头添加到数据包。该报头包含有关要向其传递数据包副本的BFER集的信息。BFER在离开BIER域之前将BIER标头从数据包中删除。BIER头被BIER域中的所有位转发路由器(BFR)所利用,以有效地沿树结构甚至是由底层信息确定的任何非循环图(通常由IGP(内部网关协议)承载)进行流量转发。

BFR根据该标头信息及其所谓的位索引转发表(BIFT)中继和复制BIER流量。BIFT保存每个可能的目的地(BFER)的下一跳信息。因此,BIFT的大小与IPMC组的数量无关。实际部署可能会将通过同一下一跳到达的目的地的转发信息分组。这甚至进一步减少了转发条目的数量,从而与BFR下一跳的数量成比例。即使数据包的BIER标头指示该下一跳有多个目的地,转发过程也可以确保下一跳仅接收到该数据包的单个副本。为了一致地转发BIER流量,通常为BIFT配置指向BFER的最短路径条目。

BIER总结

BIER是一种新的创新机制,用于有效转发和复制IPMC流量。它解决了传统IPMC解决方案的可伸缩性,操作和性能问题。后者需要在转发设备中按IPMC组状态和显式树构建,而BIER在数据包的BIER标头中编码IPMC组的目的地。当IPMC数据包进入BIER域时,报头由位转发入口路由器(BFIR)创建。BIER可很好地扩展,因为网络核心中的转发节点不需要依赖IPMC组的信息。

Optical Fiber Communication 公众号二维码

扫码关注公众号「Optical Fiber Communication」,获取更多光通信技术解读

Category: 技术文章

发表回复

要发表评论,您必须先登录。

订阅更新

订阅后,新文章发布时第一时间收到邮件通知

博主
李东霏
【香农信息技术研究院】

广告

📢 广告位招商:面向全球光通信客户 侧边栏广告位 Wechat:WaytoICT,Email:Dongfei.li@shannoninstitute.cn

标签

CPO OTN 800G NPO 光纤 光模块 PON DWDM VCSEL EML WDM 硅光 LPO 50G PON 空芯光纤 光引擎 400G ROADM 共封装光学 OCS OSNR 光交换机 调制器 1.6T 全光网 相干技术 光电探测器 DFB 光器件与模块 TFLN

最新评论

暂无评论,欢迎登录后发表第一条评论。

最近访客

👥 今日访客 -
加载中…
© 2026 WaytoICT | 蜀ICP备2020035321号-2
微信支付
支付宝
请使用 支付宝 或 微信 扫码支付